snipe-it v5.0.9 Release Notes

Release Date: 2020-11-24 // about 1 year ago
  • 🆕 New in v5.0.9

    🚀 Happy Tuesday again, friends :) Sorry for the double release today, but we discovered a conflict with the new asset counter in the sidenav and the SAML integration, since the SAML routes are loaded as a service provider. This change wouldn't affect you unless you access the SAML settings, but it's a teeny tiny update, so it's worth patching in.

    Effectively, the middleware that pulls in those asset count numbers (number of deployed, etc, to inject it into the sidebar) only gets loaded on web middleware. When using our standard routing, everything gets pulled in under that web middleware. Since this was loaded via service provider, web had to be explicitly stated (and wasn't), so the middleware that gets those totals wasn't being loaded, resulting in the variable the sidenav uses not ever being set. It's a small changeset, and it's always a little awkward to have to release twice in one day due to a missed error, but go ahead and get your upgrade on.

    👀 For a full list of changes, see the complete changelog.

    A Note on LDAP and Okta : As many of you know, the LDAP functionality was rewritten from the ground up in version 5, and while it's been working fine for many people, we are seeing some odd throttling for folks using Okta as their LDAP provider. We're in touch with Okta now, trying to get to the bottom of it (as we're unsure if we're unintentionally beating up their API without realizing it, or if something changed on their end and it was just a crappy coincidence), but in the meantime, self-hosted folks can potentially test out this PR which reverts some of that functionality back to the v4 line. This solution isn't exactly ideal, as it means the LDAP login and LDAP sync use different methods, but if it works better for Okta customers, we'll merge that into master and re-factor it to be a little less gnarly looking.

    🚀 ⚠️ IMPORTANT: This release requires PHP 7.2.0 or greater. ⚠️

    ⬆️ Upgrading

    ⚡️ If your minimum password setting in Admin > Settings was previously less than 8, you should change this to 8 or greater before upgrading. Failure to update this may cause other settings to fail on saving.

    ⚡️ If you're running into an issue with images not showing up, that's due to an outdated version of upgrade.php (outdated because of us, not you.) That script unfortunately tries (tried) to move your files to the Laravel-approved storage directory. Since that was last updated, we decided not to use that file path, so if you upgraded using upgrade.php and your images are coming up broken, please move the files in app/storage/uploads back to public/uploads and remove the symlink the upgrader created for you. (After v5.0.0, the upgrader was patched to not move those files anymore, so if you skipped the v5.0.0 upgrade you should be fine and no action is needed.)

    ⬆️ For general upgrading instructions, click here. Users who installed Snipe-IT via Git (recommended) can just run php upgrade.php.

    ⬆️ After completing the upgrade process, be sure to clear your browser cookies.

    ⬆️ Upgrading from v3

    ⬆️ Please see the upgrade instructions here.