All Versions
25
Latest Version
Avg Release Cycle
21 days
Latest Release
1183 days ago

Changelog History
Page 2

  • v1.12.0 Changes

    February 02, 2020

    ๐Ÿ”„ Changes

    ๐Ÿฑ ๐Ÿ› Bug Fixes

    ๐Ÿšง ๐Ÿงฐ Maintenance

    โš™ Dependencies and Libraries

    • โšก๏ธ chore(deps): update redis requirement from ~=3.3 to ~=3.4 (#6803) - @dependabot-preview
    • โšก๏ธ chore(deps-dev): update pre-commit requirement from ~=2.0.0 to ~=2.0.1 (#6801) - @dependabot-preview
    • โšก๏ธ chore(deps-dev): update pre-commit requirement from ~=1.21.0 to ~=2.0.0 (#6797) - @dependabot-preview

    Contributors

    ๐Ÿš€ Thanks a lot to our contributors for making this release possible:
    @codedsun, @dependabot-preview, @dependabot-preview[bot], @diru1100, @iamareebjamal and @snitin315

  • v1.11.2 Changes

    January 25, 2020
    • ๐Ÿ›  Fix celery task status endpoint
  • v1.11.1 Changes

    January 23, 2020
    • ๐Ÿ›  Fix event fee notification task being triggered every minute
  • v1.11.0 Changes

    January 23, 2020

    BREAKING: You MUST add the current secret key set in settings table in DB as SECRET_KEY environment variable before upgrading. After upgrading, the column will be removed from DB

    ๐Ÿ”„ Changes

    • ๐Ÿšš ref: remove elasticsearch initialization (#6713) - @codedsun
    • ๐Ÿšš ref: remove events-orga endpoint (#6714) - @codedsun
    • ๐Ÿ›  fix: ticket end-date can be only within event end-date (#6647) - @codedsun

    ๐Ÿฑ ๐Ÿš€ Features

    ๐Ÿฑ ๐Ÿ› Bug Fixes

    ๐Ÿšง ๐Ÿงฐ Maintenance

    โš™ Dependencies and Libraries

    • โšก๏ธ chore(deps): update python-dotenv requirement from ~=0.10.4 to ~=0.10.5 (#6760) - @dependabot-preview
    • โšก๏ธ chore(deps): update python-dotenv requirement from ~=0.10.3 to ~=0.10.4 (#6749) - @dependabot-preview
    • โšก๏ธ chore(deps): update stripe requirement from ~=2.41.1 to ~=2.42.0 (#6741) - @dependabot-preview
    • โšก๏ธ chore(deps): update pyyaml requirement from ~=5.2 to ~=5.3 (#6727) - @dependabot-preview
    • โšก๏ธ chore(deps): update arrow requirement from ~=0.15.4 to ~=0.15.5 (#6718) - @dependabot-preview
    • โšก๏ธ chore(deps): update pillow requirement from ~=6.2.1 to ~=7.0.0 (#6715) - @dependabot-preview
    • โšก๏ธ chore(deps): update stripe requirement from ~=2.41.0 to ~=2.41.1 (#6705) - @dependabot-preview
    • โšก๏ธ chore(deps): update sqlalchemy-utils requirement from ~=0.36.0 to ~=0.36.1 (#6694) - @dependabot-preview

    Contributors

    ๐Ÿš€ Thanks a lot to our contributors for making this release possible:
    @AmitAronovitch, @Rits1272, @codedsun, @dependabot-preview, @dependabot-preview[bot], @diru1100, @iamareebjamal, @kushthedude, @mrsaicharan1, @prateekj117 and @snitin315

  • v1.10.0 Changes

    December 22, 2019

    ๐Ÿ”„ Changes

    Summary

    • ๐Ÿ›  Fix event and speaker image resizing, and add management command to resize event and speaker images which remained to be resized.
      Run python manage.py fix_event_and_speaker_images to resize images which weren't resized due to the bug
    • โšก๏ธ Optimize link generation of relationships with up to 10X speedup
    • โž• Add scheduled job to automatically remove orphan ticket holders with no order ID
    • โž• Add created and modified times in ticket holder
    • ๐Ÿ‘ Allow new tickets to have same name as deleted tickets
    • ๐Ÿ›  Fix PayTM payment gateway

    ๐Ÿฑ ๐Ÿš€ Features

    • ๐Ÿ‘ท feat: add job to delete ticket holders with no order id (#6662) - @codedsun
    • โšก๏ธ feat: Optimize link generation (#6656) - @iamareebjamal
    • feat: add created_at, modified_at in ticket_holder (#6660) - @codedsun
    • feat: management command to resize images of events and speakers (#6645) - @codedsun

    ๐Ÿฑ ๐Ÿ› Bug Fixes

    • ๐Ÿ›  fix: Order Post route view (#6683) - @prateekj117
    • ๐Ÿ›  fix: changed safequery to normal query in resize image task (#6649) - @codedsun
    • ๐Ÿ›  fix: caught invalid url image exception in resize image tasks (#6648) - @codedsun
    • ๐Ÿ›  fix: canceled order mail template changed (#6643) - @codedsun
    • ๐Ÿ›  fix: Use requests to fetch event and speaker images (#6639) - @codedsun
    • ๐Ÿ›  fix: Allow tickets to have same name as deleted ones (#6628) - @codedsun
    • fix: Removing is_ticketing_enabled from event models (#6634) - @kushthedude
    • ๐Ÿ›  fix: checksum.py for PayTM (#6611) - @kushthedude

    ๐Ÿšง ๐Ÿงฐ Maintenance

    โš™ Dependencies and Libraries

    • โšก๏ธ chore(deps): update coverage requirement from ~=4.5 to ~=5.0 (#6672) - @dependabot-preview
    • โšก๏ธ chore(deps): update sqlalchemy requirement from ~=1.3.11 to ~=1.3.12 (#6671) - @dependabot-preview
    • โšก๏ธ chore(deps): update celery requirement from ~=4.3 to ~=4.4 (#6670) - @dependabot-preview
    • โšก๏ธ chore(deps): update geoip2 requirement from ~=2.9.0 to ~=3.0.0 (#6681) - @dependabot-preview
    • โšก๏ธ chore(deps): update sqlalchemy-utils requirement from ~=0.35.0 to ~=0.36.0 (#6650) - @dependabot-preview
    • โšก๏ธ chore(deps): update pyyaml requirement from ~=5.1 to ~=5.2 (#6637) - @dependabot-preview

    Contributors

    ๐Ÿš€ Thanks a lot to our contributors for making this release possible:
    @codedsun, @dependabot-preview, @dependabot-preview[bot], @diru1100, @iamareebjamal, @kushthedude and @prateekj117

  • v1.9.0 Changes

    November 28, 2019

    ๐Ÿ”„ Changes

    ๐Ÿฑ ๐Ÿš€ Features

    ๐Ÿฑ ๐Ÿ› Bug Fixes

    • ๐Ÿ›  fix: Removed decorator from stripe-authorizations (#6627) - @codedsun
    • ๐Ÿ›  fix: Check user permission before exporting (#6581) - @prateekj117
    • ๐Ÿ›  fix: Remove upcoming events from after event email text (#6624) - @codedsun

    ๐Ÿšง ๐Ÿงฐ Maintenance

    โš™ Dependencies and Libraries

    • โšก๏ธ chore(deps): update stripe requirement from ~=2.40.0 to ~=2.41.0 (#6629) - @dependabot-preview
    • โšก๏ธ chore(deps): update icalendar requirement from ~=4.0.3 to ~=4.0.4 (#6625) - @dependabot-preview
    • โšก๏ธ chore(deps): update flask-caching requirement from ~=1.4 to ~=1.8 (#6617) - @dependabot-preview

    Contributors

    ๐Ÿš€ Thanks a lot to our contributors for making this release possible:
    @codedsun, @dependabot-preview, @dependabot-preview[bot], @iamareebjamal, @kushthedude and @prateekj117

  • v1.8.0 Changes

    November 24, 2019

    ๐Ÿ”„ Changes

    ๐Ÿฑ ๐Ÿ› Bug Fixes

    ๐Ÿšง ๐Ÿงฐ Maintenance

    ๐Ÿ“š ๐Ÿ•ฎ Documentation

    • ๐Ÿ“š chore(docs): Added auth/verify-email endpoint in documentation (#6602) - @codedsun
    • ๐Ÿ“„ chore(docs): Add missing attendee endpoints (#6596) - @akshat0047
    • ๐Ÿ“„ chore(docs): Fix grammatical mistakes in docs (#6568) - @NNRepos
    • ๐Ÿš€ chore(docs): Remove broken docker deploy button (#6561) - @Swap76
    • โšก๏ธ chore(docs): Correct API docs for update order (#6546) - @Tlazypanda

    โš™ Dependencies and Libraries

    • โšก๏ธ chore(deps): update pycryptodome requirement from ~=3.9.3 to ~=3.9.4 (#6605) - @dependabot-preview
    • โšก๏ธ chore(deps): update pycryptodome requirement from ~=3.9.2 to ~=3.9.3 (#6593) - @dependabot-preview
    • โšก๏ธ chore(deps): update sqlalchemy requirement from ~=1.3.10 to ~=1.3.11 (#6592) - @dependabot-preview
    • โšก๏ธ chore(deps): update pycryptodome requirement from ~=3.9.1 to ~=3.9.2 (#6589) - @dependabot-preview
    • โšก๏ธ chore(deps): update gunicorn requirement from ~=19.9 to ~=20.0 (#6587) - @dependabot-preview
    • โšก๏ธ chore(deps): update stripe requirement from ~=2.39.0 to ~=2.40.0 (#6588) - @dependabot-preview
    • โšก๏ธ chore(deps): update requests-oauthlib requirement from ~=1.2 to ~=1.3 (#6582) - @dependabot-preview
    • โšก๏ธ chore(deps): update stripe requirement from ~=2.38.0 to ~=2.39.0 (#6583) - @dependabot-preview
    • โšก๏ธ chore(deps): update apscheduler requirement from ~=3.6.2 to ~=3.6.3 (#6578) - @dependabot-preview
    • โšก๏ธ chore(deps): update pycryptodome requirement from ~=3.9.0 to ~=3.9.1 (#6574) - @dependabot-preview
    • โšก๏ธ chore(deps): update apscheduler requirement from ~=3.6.1 to ~=3.6.2 (#6576) - @dependabot-preview
    • โšก๏ธ chore(deps): update arrow requirement from ~=0.15.2 to ~=0.15.4 (#6577) - @dependabot-preview
    • โšก๏ธ chore(deps): update sqlalchemy-utils requirement from ~=0.34.2 to ~=0.35.0 (#6564) - @dependabot-preview
    • โšก๏ธ chore(deps): update stripe requirement from ~=2.37.2 to ~=2.38.0 (#6562) - @dependabot-preview
    • โšก๏ธ chore(deps): update flask-jwt-extended requirement from ~=3.23.0 to ~=3.24.1 (#6551) - @dependabot-preview
    • chore(deps): bump python-pentabarf-xml from 0.19 to 0.20 (#6549) - @dependabot-preview
    • โšก๏ธ chore(deps): update psycopg2-binary requirement from ~=2.8.3 to ~=2.8.4 (#6547) - @dependabot-preview
    • โšก๏ธ chore(deps): update pillow requirement from ~=6.2.0 to ~=6.2.1 (#6548) - @dependabot-preview

    Contributors

    ๐Ÿš€ Thanks a lot to our contributors for making this release possible:
    @NNRepos, @Swap76, @Tlazypanda, @akshat0047, @codedsun, @dependabot-preview, @dependabot-preview[bot], @iamareebjamal and @prateekj117

  • v1.7.0 Changes

    October 19, 2019

    ๐Ÿ”„ Changes

    • ๐Ÿ’ฅ BREAKING: Requires Python 3.7
    • โž• Add info endpoint to get server version
    • โž• Add management script to switch modules on or off
    • ๐Ÿณ Increase gunicorn workers in docker and add options for configuration
    • ๐Ÿš‘ Fix CSV export (included as hotfix in previous version)
    • ๐Ÿ›  Fix order PDF not found errors by mounting generated folder in docker
    • ๐Ÿ›  Fix ICal attribute errors and add tests
    • ๐Ÿ›  Fix Pentabarf export and add tests
    • โž• Add workaround for multiprocess engine forking
    • ๐Ÿ‘‰ Use pool pre ping option to avoid dropped connections
    • โž• Add .env in docker compose to override environment variables
    • ๐Ÿ”ง Configure redis and celery in sentry integration
    • Convert some classes to dataclasses
    • โšก๏ธ Update dependencies

    ๐Ÿฑ ๐Ÿš€ Features

    ๐Ÿฑ ๐Ÿ› Bug Fixes

    ๐Ÿšง ๐Ÿงฐ Maintenance

    • ๐Ÿณ chore: Add generated folder to docker volume mount (#6512) - @iamareebjamal
    • ๐Ÿšš chore: Remove populate and fix various dredd tests (#6506) - @iamareebjamal
    • ๐Ÿšš chore: Remove debugging print statements from listener (#6502) - @iamareebjamal
    • โœ… chore: Change flask-rest-jsonapi to taggd and tested version (#6492) - @iamareebjamal
    • ๐Ÿณ chore: Use Python 3.7 in docker (#6490) - @iamareebjamal
    • ๐Ÿณ chore: Add .env in docker compose and ignore override (#6488) - @iamareebjamal
    • feat: Integrate sqlalchemy, redis and celery in sentry

    ๐Ÿ“š ๐Ÿ•ฎ Documentation

    โš™ Dependencies and Libraries

    • โšก๏ธ chore(deps): update sentry-sdk requirement from ~=0.12 to ~=0.13 (#6534) - @dependabot-preview
    • โšก๏ธ chore(deps): update sqlalchemy requirement from ~=1.3.9 to ~=1.3.10 (#6519) - @dependabot-preview
    • โšก๏ธ chore(deps): update stripe requirement from ~=2.37.1 to ~=2.37.2 (#6515) - @dependabot-preview
    • โšก๏ธ chore(deps): update sqlalchemy requirement from ~=1.3.8 to ~=1.3.9 (#6500) - @dependabot-preview
    • โšก๏ธ chore(deps): update flask-limiter requirement from ~=1.0.1 to ~=1.1.0 (#6498) - @dependabot-preview
    • โšก๏ธ chore(deps): update pillow requirement from ~=6.1.0 to ~=6.2.0 (#6485) - @dependabot-preview
    • โšก๏ธ chore(deps): update stripe requirement from ~=2.36.2 to ~=2.37.1 (#6469)
    • โšก๏ธ chore(deps-dev): update pylint requirement from ~=2.3 to ~=2.4
    • โšก๏ธ chore(deps): update sentry-sdk requirement from ~=0.11 to ~=0.12
    • โšก๏ธ chore(deps): update arrow requirement from ~=0.15.1 to ~=0.15.2
    • โšก๏ธ chore(deps): update stripe requirement from ~=2.36.1 to ~=2.36.2
    • โšก๏ธ chore(deps): update sendgrid requirement from ~=6.0 to ~=6.1
    • โšก๏ธ chore(deps): update pycryptodome requirement from ~=3.8.2 to ~=โ€ฆ (#6442)
    • โšก๏ธ chore(deps): Update pycrypto to fork
    • โšก๏ธ chore(deps): update sqlalchemy requirement from ~=1.3.7 to ~=1.โ€ฆ (#6421)
    • โšก๏ธ chore(deps): update flask-jwt-extended requirement from ~=3.21.โ€ฆ (#6439)
    • โšก๏ธ chore(deps): update flask-jwt-extended requirement from ~=3.21.โ€ฆ (#6439)
    • โšก๏ธ chore(deps): update stripe requirement from ~=2.35.1 to ~=2.36.0 (#6440)
    • โšก๏ธ chore(deps): update arrow requirement from ~=0.15.0 to ~=0.15.1 (#6441)
    • โšก๏ธ chore(deps): update sqlalchemy-utils requirement from ~=0.34.1โ€ฆ (#6403)
    • โšก๏ธ chore(deps): update stripe requirement from ~=2.35.0 to ~=2.35.1 (#6404)
    • โšก๏ธ chore(deps): update arrow requirement from ~=0.14.5 to ~=0.15.0 (#6437)

    Contributors

    ๐Ÿš€ Thanks a lot to our contributors for making this release possible:
    @akshat0047, @chiral-carbon, @dependabot-preview, @dependabot-preview[bot], @iamareebjamal, @lladhibhutall, @mrsaicharan1, @prateekj117 and @rbstrachan

  • v1.6.2 Changes

    October 01, 2019

    ๐Ÿš€ Same release as v1.6.1 with a dependency fix. Please use this version and ignore v1.6.1

  • v1.6.1 Changes

    October 01, 2019

    ๐Ÿš‘ This is a hotfix release fixing sessions CSV export and adding sentry integrations of redis, SQLAlchemy and celery

    Note : Please use v1.6.2, and ignore this release