Open Web Analytics v1.6.9 Release Notes

Release Date: 2020-05-12 // 3 months ago
  • ! IMPORTANT: This release requires a schema update. The update can be applied via the browser (you will be prompted when viewing analytics/reporting) or you can use the command line interface (CLI). You must apply the update in order for API's and tracking to work.

    ! IMPORTANT: The WordPress plugin and integration have changed! As of this release, new installs must do a standalone install of OWA first before activating the WordPress plugin. Also, existing users of the plugin will need to reset their OWA admin user password in order for tracking to work properly.

    ! IMPORTANT: The API endpoint has changed!. This release changes the API endpoint, request methods, and response formats. It's a major change. If you rely on the existing endpoint for data access you will need to update your API calls before upgrading to this release! The good news is that you can do a lot more via the API and we won't have breaking changes like this anymore. see: https://github.com/Open-Web-Analytics/Open-Web-Analytics/wiki/REST-API

    Reminder: You must install and run Composer to download dependencies when checking out code from GitHub. See https://github.com/Open-Web-Analytics/Open-Web-Analytics/wiki/Installing-from-Github for more details.

    📦 For a fully packaged distribution use: owa_1.6.9_packaged.tar

    🚀 This release contains numerous changes to OWA's APIs and

    • 🔋 Feature: Javascript Tracker Hooks Framework #579
    • 🔋 Feature: Clean URLs under Apache for for REST API #563
    • 🔋 Feature: WordPress Plugin Changes #560
    • 🔋 Feature: Reporting Pages Design Refresh #557
    • 🔋 Feature: CLI command to re-crawl document URLs. #523
    • 🔋 Feature: Added Search engine duckduckgo #533
    • 🔋 Feature: Domstream Screen resolution #534
    • 🔋 Feature: More REST API Routes and Changes #535 #536
    • 🛠 Bugfix: Clickstream timestamp zeros not get displayed #550
    • 🐛 Bugifx: Proper link to P3P policy website. #551
    • 🛠 Bugfix: Heatmap and Domstream fixes #567
    • 🛠 Bugfix: Fixing random notice and adding admin notices to WP Plugin

Previous changes from v1.6.8

  • IMPORTANT: OWA's PHP requirements have changed. PHP 5.6 is the new minimum and PHP 7.x is highly recommended.

    NOTE: As of this release you must install and run Composer to download dependencies when checking out code from GitHub. See https://github.com/Open-Web-Analytics/Open-Web-Analytics/wiki/Installing-from-Github for more details.

    📦 For a fully packaged distribution use: owa_1.6.8_packaged.tar

    • 🛠 Bugfix: WordPress install not working #525