The Bug Genie v4.3.1 Release Notes

Release Date: 2019-03-25 // over 3 years ago
  • ๐Ÿ›  This is a bugfix release to fix an issue with an incorrect php dependancy.


Previous changes from v4.3.0

  • ๐Ÿš€ This is the final 4.3.0 release. This release requires php 7.1 or higher, and you need to run composer update after downloading, before running the installation routine.

    ๐Ÿ‘€ In addition to fixing quite a number of bugs, see below for an incomplete list of the most notable changes.

    Known issues: https://issues.thebuggenie.com/thebuggenie/issues/find/saved_search/269/search/1
    ๐Ÿ†• New issue: https://issues.thebuggenie.com/thebuggenie/releases

    ๐Ÿ†• New features:

    • ๐Ÿ†• New comment layout, with conversation view and direct replies
    • ๐Ÿ‘Œ Improved presentation of priority and severity fields

    Other changes:

    • ๐Ÿ‘Œ Improves display of a lot of setting screens
    • โšก๏ธ Module updates and automatic module installation now requires a valid thebuggenie.com subscription
    • โž• Added setting screen for saving the thebuggenie.com license

    Framework changes:

    • โšก๏ธ Updates b2db dependency from v2.0 to v3.0, including a total rewrite of all database handling code in thebuggenie.
    • โšก๏ธ Updates fontawesome from 4 to 5
    • โœ‚ Removes php 7.0 compatibility, requires 7.1 or newer