All Versions
32
Latest Version
Avg Release Cycle
24 days
Latest Release
358 days ago

Changelog History
Page 1

  • v5.0.11 Changes

    December 09, 2020

    πŸ†• New in v5.0.11

    πŸš€ Happy Tuesday! Just a small bug fix release that should make SAML debugging a little easier and fixed a few minor bugs.

    πŸ›  Fixed

    • πŸ›  Fixed typo on route for licenses
    • πŸ›  Fixed #8147 - allow webp image format for public file uploads
    • πŸ›  Fixed #8472 (again) - LDAP sync was assigning a bad default location (#8846)
    • Only overwrite notes if the LDAP user is new
    • βž• Added LDAP flag in users GET API for #8741

    βž• Added / Improved

    • πŸ‘ Allow saml to be more easily debugged

    πŸ‘€ For a full list of changes, see the complete changelog.

    πŸš€ ⚠️ IMPORTANT: This release requires PHP 7.2.0 or greater. ⚠️

    ⬆️ Upgrading

    ⚑️ If your minimum password setting in Admin > Settings was previously less than 8, you should change this to 8 or greater before upgrading. Failure to update this may cause other settings to fail on saving.

    ⚑️ If you're running into an issue with images not showing up, that's due to an outdated version of upgrade.php (outdated because of us, not you.) That script unfortunately tries (tried) to move your files to the Laravel-approved storage directory. Since that was last updated, we decided not to use that file path, so if you upgraded using upgrade.php and your images are coming up broken, please move the files in app/storage/uploads back to public/uploads and remove the symlink the upgrader created for you. (After v5.0.0, the upgrader was patched to not move those files anymore, so if you skipped the v5.0.0 upgrade you should be fine and no action is needed.)

    ⬆️ For general upgrading instructions, click here. Users who installed Snipe-IT via Git (recommended) can just run php upgrade.php.

    ⬆️ After completing the upgrade process, be sure to clear your browser cookies.

    ⬆️ Upgrading from v3

    ⬆️ Please see the upgrade instructions here.

  • v5.0.10 Changes

    December 01, 2020

    πŸ†• New in v5.0.10

    πŸš€ Happy Monday, friends :) This is a bug fix release that tightens up some UI stuff, fixes an issue with the location importer parent locations, and (hopefully) puts to bed an issue we've been seeing with Okta users who are trying to use the LDAP sync utility. We also fixed an issue where the email logo that was uploaded wasn't being honored in the actual emails that were sent.

    πŸ›  Fixed

    • πŸ›  Fixed #8794 - Switched to firstOrCreate to create parents on location import cli
    • πŸ›  Fixed #8810 - email logo was not being used in emails
    • πŸ›  Fixed #8814 - added App\Models\Recipients\AlertRecipient
    • Fixed #8797 - use html_entity_decode in fullName presenter for User
    • πŸ”€ Forward-port of the old LDAP sync system to solve Okta sync issues that were resulting in admin limit error (#8801)

    βž• Added / Improved

    • βž• Added location to searchableRelations for asset
    • βž• Added purchase order and order number to user > licenses view
    • πŸ’» Branding page UI improvements (image previews inline)
    • ⬆️ Skip posix_getpwuid in upgrader if posix isn’t installed
    • βœ… Switch backup files array order to show latest first [ch15486]

    πŸ‘€ For a full list of changes, see the complete changelog.

    πŸš€ ⚠️ IMPORTANT: This release requires PHP 7.2.0 or greater. ⚠️

    ⬆️ Upgrading

    ⚑️ If your minimum password setting in Admin > Settings was previously less than 8, you should change this to 8 or greater before upgrading. Failure to update this may cause other settings to fail on saving.

    ⚑️ If you're running into an issue with images not showing up, that's due to an outdated version of upgrade.php (outdated because of us, not you.) That script unfortunately tries (tried) to move your files to the Laravel-approved storage directory. Since that was last updated, we decided not to use that file path, so if you upgraded using upgrade.php and your images are coming up broken, please move the files in app/storage/uploads back to public/uploads and remove the symlink the upgrader created for you. (After v5.0.0, the upgrader was patched to not move those files anymore, so if you skipped the v5.0.0 upgrade you should be fine and no action is needed.)

    ⬆️ For general upgrading instructions, click here. Users who installed Snipe-IT via Git (recommended) can just run php upgrade.php.

    ⬆️ After completing the upgrade process, be sure to clear your browser cookies.

    ⬆️ Upgrading from v3

    ⬆️ Please see the upgrade instructions here.

  • v5.0.9 Changes

    November 24, 2020

    πŸ†• New in v5.0.9

    πŸš€ Happy Tuesday again, friends :) Sorry for the double release today, but we discovered a conflict with the new asset counter in the sidenav and the SAML integration, since the SAML routes are loaded as a service provider. This change wouldn't affect you unless you access the SAML settings, but it's a teeny tiny update, so it's worth patching in.

    Effectively, the middleware that pulls in those asset count numbers (number of deployed, etc, to inject it into the sidebar) only gets loaded on web middleware. When using our standard routing, everything gets pulled in under that web middleware. Since this was loaded via service provider, web had to be explicitly stated (and wasn't), so the middleware that gets those totals wasn't being loaded, resulting in the variable the sidenav uses not ever being set. It's a small changeset, and it's always a little awkward to have to release twice in one day due to a missed error, but go ahead and get your upgrade on.

    πŸ‘€ For a full list of changes, see the complete changelog.

    A Note on LDAP and Okta : As many of you know, the LDAP functionality was rewritten from the ground up in version 5, and while it's been working fine for many people, we are seeing some odd throttling for folks using Okta as their LDAP provider. We're in touch with Okta now, trying to get to the bottom of it (as we're unsure if we're unintentionally beating up their API without realizing it, or if something changed on their end and it was just a crappy coincidence), but in the meantime, self-hosted folks can potentially test out this PR which reverts some of that functionality back to the v4 line. This solution isn't exactly ideal, as it means the LDAP login and LDAP sync use different methods, but if it works better for Okta customers, we'll merge that into master and re-factor it to be a little less gnarly looking.

    πŸš€ ⚠️ IMPORTANT: This release requires PHP 7.2.0 or greater. ⚠️

    ⬆️ Upgrading

    ⚑️ If your minimum password setting in Admin > Settings was previously less than 8, you should change this to 8 or greater before upgrading. Failure to update this may cause other settings to fail on saving.

    ⚑️ If you're running into an issue with images not showing up, that's due to an outdated version of upgrade.php (outdated because of us, not you.) That script unfortunately tries (tried) to move your files to the Laravel-approved storage directory. Since that was last updated, we decided not to use that file path, so if you upgraded using upgrade.php and your images are coming up broken, please move the files in app/storage/uploads back to public/uploads and remove the symlink the upgrader created for you. (After v5.0.0, the upgrader was patched to not move those files anymore, so if you skipped the v5.0.0 upgrade you should be fine and no action is needed.)

    ⬆️ For general upgrading instructions, click here. Users who installed Snipe-IT via Git (recommended) can just run php upgrade.php.

    ⬆️ After completing the upgrade process, be sure to clear your browser cookies.

    ⬆️ Upgrading from v3

    ⬆️ Please see the upgrade instructions here.

  • v5.0.8 Changes

    November 24, 2020

    πŸ†• New in v5.0.8

    πŸš€ Happy Tuesday, friends :) This is largely a bug fix release for some unusual use-cases that folks have been kind enough to share with us, including the dashboard pie chart, SAML integration, and LDAP syncing.

    It also addresses an issue where users of some email clients (such as Gmail) would not have the images in notifications loading properly. (This is due to Gmail opting not to parse base_64 encoded images.) The attachment method has been changed to cid, so that issue should be resolved by upgrading to this version.

    πŸ‘€ For a full list of changes, see the complete changelog.

    A Note on LDAP and Okta : As many of you know, the LDAP functionality was rewritten from the ground up in version 5, and while it's been working fine for many people, we are seeing some odd throttling for folks using Okta as their LDAP provider. We're in touch with Okta now, trying to get to the bottom of it (as we're unsure if we're unintentionally beating up their API without realizing it, or if something changed on their end and it was just a crappy coincidence), but in the meantime, self-hosted folks can potentially test out this PR which reverts some of that functionality back to the v4 line. This solution isn't exactly ideal, as it means the LDAP login and LDAP sync use different methods, but if it works better for Okta customers, we'll merge that into master and re-factor it to be a little less gnarly looking.

    πŸ›  Fixed

    • πŸ›  Fixes #8584, #8654, #8727 - fixes and improvements for SAML (#8795)
    • πŸ›  Fix for #8772 - initial LDAP import of users are deactivated (#8776)
    • πŸ›  Fixed #8753 - create-asset-from-model did not preselect the model
    • πŸ›  Fixed #8749 - added more default colors to prevent missing index in pie chart math
    • πŸ›  Fix for 500-page on deactivated LDAP user trying to log in (#8774)
    • Prevent license categories from being deleted if there are licenses in it
    • πŸ›  Fixed #8773 - wrong path for suppliers image on suppliers edit
    • πŸ›  Fixed #8601 - Switched to β€œattachment” from β€œbase64”
    • πŸ›  Fixed #8765 - UI not indicating model is required
    • πŸ›  Fixed #8769 - incorrect translation for β€œDELETE” in purge for German

    βž• Added

    • βž• Added #8781 - asset count by status type in sidenav (#8806)
    • βž• Added a new UAC setting to valid User Accounts for Active Directory (#8775)
    • βž• Added img-responsive class to preview images for suppliers, etc

    πŸ‘Œ Improvements

    • πŸ”„ Change license serial type to TEXT for longer license files (#8782)
    • ⚑️ Updated translations with new strings

    πŸš€ ⚠️ IMPORTANT: This release requires PHP 7.2.0 or greater. ⚠️

    ⬆️ Upgrading

    ⚑️ If your minimum password setting in Admin > Settings was previously less than 8, you should change this to 8 or greater before upgrading. Failure to update this may cause other settings to fail on saving.

    ⚑️ If you're running into an issue with images not showing up, that's due to an outdated version of upgrade.php (outdated because of us, not you.) That script unfortunately tries (tried) to move your files to the Laravel-approved storage directory. Since that was last updated, we decided not to use that file path, so if you upgraded using upgrade.php and your images are coming up broken, please move the files in app/storage/uploads back to public/uploads and remove the symlink the upgrader created for you. (After v5.0.0, the upgrader was patched to not move those files anymore, so if you skipped the v5.0.0 upgrade you should be fine and no action is needed.)

    ⬆️ For general upgrading instructions, click here. Users who installed Snipe-IT via Git (recommended) can just run php upgrade.php.

    ⬆️ After completing the upgrade process, be sure to clear your browser cookies.

    ⬆️ Upgrading from v3

    ⬆️ Please see the upgrade instructions here.

  • v5.0.7 Changes

    November 17, 2020

    πŸ†• New in v5.0.7

    πŸš€ Happy Tuesday, everyone! This is a bug fix release that should handle a bunch of smaller UI bugs, and will hopefully help with some LDAP quirkiness you've all been kind enough to document and report for us.

    πŸš€ Note: We did miss updating version.php to reflect that this is from the master branch, so it may be confusing to see develop instead of master in your Snipe-IT footer, but this release is definitely based off the master branch. It seemed like it would be more confusing to delete/edit the tag after it was already pushed.

    πŸ›  Fixed

    • πŸ›  Fixed [ch15347] - added status in Depreciation Report
    • πŸ›  Fixed [ch9336] - Removed time in Depreciation report (it's a date, not a datetime field)
    • πŸ›  Fixed #8448 - β€œundefined” when testing email from quickstart
    • ⚑️ Throw an error if the asset cannot be updated in the merge-users script (possible when assets fail validation on save due to serial uniqueness constraint, etc)
    • βž• Add ability to checkout an asset if the user it’s assigned_to isn’t valid. This would only happen if a merge-users went wonky
    • Make last_checkout and expected_checkin fillable for API calls
    • πŸ›  Fixed css to the bootstrap popovers for all dark mode skins (#8714)
    • Exclude blank LDAP attributes
    • πŸ›  Fixed markdown in expiring licenses alert
    • πŸ›  Fixed #8726 - disallow archived assets to be checked out
    • 🌐 Enable translations of checkin notifications (#8235) and accepted assets page (#8237)
    • 🍱 Switch to use same convention for file names on licenses as we do on assets
    • πŸ›  Fixed #8715 - wrong API url for unaccepted assets
    • πŸ›  Fixed offset issue for #8732
    • πŸ›  Fixed #8669 - Allow application/xml in SAML upload in Safari
    • ⚑️ Updated Laravel version in README
    • βž• Added S3 url into CSP
    • πŸ›  Fixes for #8732 - Flysystem paths, S3 migrator script
    • πŸ›  Fixed #8733 - typo in unaccepted assets report
    • πŸ›  Fixed #8609 - custom fieldsets not draggable anymore (regression)
    • πŸ›  Fixed #8544 - escaping on maintenance notes
    • πŸ›  Fixed #8737 - incorrect validation string for components qty update
    • πŸ›  Fixed #8746 - missing comma in a translation file (#8756)
    • βœ… Re-add LDAP "test login" feature to LDAP settings (helps with #8751 and #8757)
    • πŸ›  Fixed #7850 - allow .xlsx file in upload. (#8386)
    • πŸ›  Fixed Spanish translations duplicate string
    • πŸ›  Fixed #8482 - Ubuntu version (#8598)
    • βœ‚ Removed duplicate date from date macro
    • πŸ”€ Attempt to solve LDAP sync overriding administrator choices (Fixes: #8734, #8670, and #8617) #8742

    βž• Added

    • βž• Added Checkout Date Time to Asset Details Page [ch1418]
    • ⚑️ Updated most recent translations
    • πŸ”Š Experimental script to find mismatched IDs based on logs
    • βž• Added more detail and dryrun to assigned_to vs log checker script
    • βž• Added artisan command to purge logins
    • βž• Added link to bricelabelle/snipe-it-bulkedit
    • πŸ›  Fixed #8647 - Added additional help info on importer page

    πŸ‘Œ Improvements

    • 🚚 Moved a few of the user edit fields to make more sense (optional stuff further down)
    • βž• Added clarity in language as to what the activated flag does on LDAP screens
    • πŸ‘Œ Improved 2FA reset layout
    • πŸ‘Œ Improved upgrade.php script to check for PHP extensions (#8712)

    πŸš€ ⚠️ IMPORTANT: This release requires PHP 7.2.0 or greater. ⚠️

    ⬆️ Upgrading

    ⚑️ If your minimum password setting in Admin > Settings was previously less than 8, you should change this to 8 or greater before upgrading. Failure to update this may cause other settings to fail on saving.

    ⚑️ If you're running into an issue with images not showing up, that's due to an outdated version of upgrade.php (outdated because of us, not you.) That script unfortunately tries (tried) to move your files to the Laravel-approved storage directory. Since that was last updated, we decided not to use that file path, so if you upgraded using upgrade.php and your images are coming up broken, please move the files in app/storage/uploads back to public/uploads and remove the symlink the upgrader created for you. (After v5.0.0, the upgrader was patched to not move those files anymore, so if you skipped the v5.0.0 upgrade you should be fine and no action is needed.)

    ⬆️ For general upgrading instructions, click here. Users who installed Snipe-IT via Git (recommended) can just run php upgrade.php.

    πŸ‘€ For a full list of changes, see the changelog.

    ⬆️ After completing the upgrade process, be sure to clear your browser cookies.

    ⬆️ Upgrading from v3

    ⬆️ Please see the upgrade instructions here.

  • v5.0.6 Changes

    November 10, 2020

    πŸ†• New in v5.0.6

    This is a small point release that adds a little extra functionality for extending the life of your API keys. Keys prior to this version will expire in one year, however we've added a much longer expiration for these now, which defaults to 20 years. If you'd like to override this with a shorter (or longer) expiration, add API_TOKEN_EXPIRATION_YEARS=X (where X is the number of years you want them to expire in) to your .env and clear your config cache with php artisan config:cache.

    Screen Shot 2020-11-09 at 11 19 45 PM

    πŸš€ We certainly could have waited to push this out into a release later in the week, but it seemed too useful not to share it right away.

    βž• Added

    • Added created_at and expires_at to Account API token UI
    • βž• Added configured API expiration in years to API token sidebar for clarity
    • πŸ›  Fixed #8673 - added category to accessories listing on Account > Assigned Assets

    πŸš€ ⚠️ IMPORTANT: This release requires PHP 7.2.0 or greater. ⚠️

    ⬆️ Upgrading

    ⚑️ If your minimum password setting in Admin > Settings was previously less than 8, you should change this to 8 or greater before upgrading. Failure to update this may cause other settings to fail on saving.

    ⚑️ If you're running into an issue with images not showing up, that's due to an outdated version of upgrade.php (outdated because of us, not you.) That script unfortunately tries (tried) to move your files to the Laravel-approved storage directory. Since that was last updated, we decided not to use that file path, so if you upgraded using upgrade.php and your images are coming up broken, please move the files in app/storage/uploads back to public/uploads and remove the symlink the upgrader created for you. (After v5.0.0, the upgrader was patched to not move those files anymore, so if you skipped the v5.0.0 upgrade you should be fine and no action is needed.)

    ⬆️ For general upgrading instructions, click here. Users who installed Snipe-IT via Git (recommended) can just run php upgrade.php.

    πŸ‘€ For a full list of changes, see the changelog.

    ⬆️ After completing the upgrade process, be sure to clear your browser cookies.

    ⬆️ Upgrading from v3

    ⬆️ Please see the upgrade instructions here.

  • v5.0.5 Changes

    November 10, 2020

    πŸ†• New in v5.0.5

    πŸš€ This is a bug fix release that should handle some of the issues reported over the past week or so.

    We'll be hitting them back as quickly as you can throw issues at us, so keep them coming! We appreciate it :)

    πŸ›  Fixed

    • πŸ›  Fixed #8613 - 500 error on deleted users API call
    • πŸ›  Fixed #8613 - Added deleted_at to user API response, added all=true to include deleted and not-deleted in one call
    • πŸ›  Fixed min requirement for passwords in lang files
    • πŸ›  Fixed #8603 - Use correct CSS path for signature-pad.min.css
    • πŸ›  Fixed send creds checkbox in create user form
    • πŸ›  Fixed (Re-Added) Accessories API endpoint
    • πŸ›  Fixed #8595 - Updated backup config file for compatibility with later versions of spatie-backup
    • πŸ›  Fixed AD Accounts with delegation disabled
    • πŸ›  Fixed spanish translation parse error
    • Fixed the LDAP_TIME_LIM env var for ldap sync of very large directories

    βž• Added

    • βž• Added Settings > Security option and validation to disallow password to be the same as username, email, etc
    • ⚑️ Updated latest translations with latest from CrowdIn
    • πŸ›  Fixed #8604 - issue with lists not loading if you have many custom fields (PR #8706)
    • πŸ›  Fixed #8680 - use location image path in location details page

    πŸ‘Œ Improved

    • πŸ“š Documentation on SAML

    πŸš€ IMPORTANT: This release requires PHP 7.2.0 or greater.

    ⬆️ Upgrading

    ⚑️ If your minimum password setting in Admin > Settings was previously less than 8, you should change this to 8 or greater before upgrading. Failure to update this may cause other settings to fail on saving.

    ⚑️ If you're running into an issue with images not showing up, that's due to an outdated version of upgrade.php (outdated because of us, not you.) That script unfortunately tries (tried) to move your files to the Laravel-approved storage directory. Since that was last updated, we decided not to use that file path, so if you upgraded using upgrade.php and your images are coming up broken, please move the files in app/storage/uploads back to public/uploads and remove the symlink the upgrader created for you. (After v5.0.0, the upgrader was patched to not move those files anymore, so if you skipped the v5.0.0 upgrade you should be fine and no action is needed.)

    ⬆️ For general upgrading instructions, click here. Users who installed Snipe-IT via Git (recommended) can just run php upgrade.php.

    πŸ‘€ For a full list of changes, see the changelog.

    ⬆️ After completing the upgrade process, be sure to clear your browser cookies.

    ⬆️ Upgrading from v3

    ⬆️ Please see the upgrade instructions here.

  • v5.0.4 Changes

    October 26, 2020

    πŸ†• New in v5.0.4

    πŸš€ This is a bug fix release that should handle some of the issues reported over the past few days.

    We'll be hitting them back as quickly as you can throw issues at us, so keep them coming! We appreciate it :)

    πŸ›  Fixed

    • βž• Add a new custom validator for Users to prevent someone from managing themselves - this should resolve issues creating users via GUI and API where it would throw an erroneous "Manager ID and user ID cannot be the same" error.
    • Include audit settings text in settings overview so they get picked up by the settings filter box
    • Exclude the config directory from backups
    • πŸ›  Fixed #8537 - wrong sorting on dashboard
    • πŸ›  Fixed #8563 - Clean up AdLdap2 integration to better handle paged result-sets

    πŸš€ IMPORTANT: This release requires PHP 7.1.3 or greater.

    ⬆️ Upgrading

    ⚑️ If your minimum password setting in Admin > Settings was previously less than 8, you should change this to 8 or greater before upgrading. Failure to update this may cause other settings to fail on saving.

    ⚑️ If you're running into an issue with images not showing up, that's due to an outdated version of upgrade.php (outdated because of us, not you.) That script unfortunately tries (tried) to move your files to the Laravel-approved storage directory. Since that was last updated, we decided not to use that file path, so if you upgraded using upgrade.php and your images are coming up broken, please move the files in app/storage/uploads back to public/uploads and remove the symlink the upgrader created for you. (After v5.0.0, the upgrader was patched to not move those files anymore, so if you skipped the v5.0.0 upgrade you should be fine and no action is needed.)

    ⬆️ For general upgrading instructions, click here. Users who installed Snipe-IT via Git (recommended) can just run php upgrade.php.

    πŸ‘€ For a full list of changes, see the changelog.

    ⬆️ After completing the upgrade process, be sure to clear your browser cookies.

    ⬆️ Upgrading from v3

    ⬆️ Please see the upgrade instructions here.

  • v5.0.3 Changes

    October 23, 2020

    πŸ†• New in v5.0.3

    ⚑️ If your minimum password setting in Admin > Settings was previously less than 8, you should change this to 8 or greater before upgrading. Failure to update this may cause other settings to fail on saving.

    πŸš€ This is a bug fix release that should handle some of the issues reported over the past few days.

    ⚑️ If you're running into an issue with images not showing up, that's due to an outdated version of upgrade.php (outdated because of us, not you.) That script unfortunately tries (tried) to move your files to the Laravel-approved storage directory. Since that was last updated, we decided not to use that file path, so if you upgraded using upgrade.php and your images are coming up broken, please move the files in app/storage/uploads back to public/uploads and remove the symlink the upgrader created for you. (After v5.0.0, the upgrader was patched to not move those files anymore, so if you skipped the v5.0.0 upgrade you should be fine and no action is needed.)

    We'll be hitting them back as quickly as you can throw issues at us, so keep them coming! We appreciate it :)

    πŸ›  Fixed

    • Possible fix to #8563 - unset $ldapUsers to avoid OOM'ing
    • βž• Added last_checkout and notes from pivot for accessories
    • πŸ›  Fixed #8597 - Added leading slash to notifications console commands
    • πŸ›  Fixed #8558 - error on asset acceptance when no sig is required
    • πŸ›  Fixed #8576 - switch to HTML from markdown
    • Temp fix for #8561 - manager_id validation error
    • βž• Added https://gravatar address to CSP
    • πŸ‘‰ Use the form partial for avatar uploads
    • πŸ›  Fix for legacy location_id=0 issue

    πŸš€ IMPORTANT: This release requires PHP 7.1.3 or greater.

    ⬆️ Upgrading

    ⬆️ For general upgrading instructions, click here. Users who installed Snipe-IT via Git (recommended) can just run php upgrade.php.

    πŸ‘€ For a full list of changes, see the changelog.

    ⬆️ After completing the upgrade process, be sure to clear your browser cookies.

    ⬆️ Upgrading from v3

    ⬆️ Please see the upgrade instructions here.

  • v5.0.2 Changes

    October 23, 2020

    πŸ†• New in v5.0.2

    ⚑️ If your minimum password setting in Admin > Settings was previously less than 8, you should change this to 8 or greater before upgrading. Failure to update this may cause other settings to fail on saving.

    πŸš€ This is a bug fix release that should handle some of the issues reported over the past few days.

    ⚑️ If you're running into an issue with images not showing up, that's due to an outdated version of upgrade.php (outdated because of us, not you.) That script unfortunately tries (tried) to move your files to the Laravel-approved storage directory. Since that was last updated, we decided not to use that file path, so if you upgraded using upgrade.php and your images are coming up broken, please move the files in app/storage/uploads back to public/uploads and remove the symlink the upgrader created for you.

    We'll be hitting them back as quickly as you can throw issues at us, so keep them coming! We appreciate it :)

    πŸ›  Fixed

    • πŸ›  Fixed #8562 - manufacturer logo upload failing
    • βž• Add a dirtiness check to slim down JSON LDAP sync summaries
    • πŸ›  Fix for #8580 - Error 500 on custom asset report having assets with model without Depreciation
    • Fixed language for the ad_append_domain_help string
    • πŸ›  Fixed #8590 - unable to checkin and delete from user view
    • πŸ›  Fixed #8589 - unable to accept asset
    • πŸ›  Fixed #8585 - requested assets page blank
    • πŸ›  Fixed signature issue on accepted assets - related to #8577

    πŸš€ IMPORTANT: This release requires PHP 7.1.3 or greater.

    ⬆️ Upgrading

    ⬆️ For general upgrading instructions, click here. Users who installed Snipe-IT via Git (recommended) can just run php upgrade.php.

    πŸ‘€ For a full list of changes, see the changelog.

    ⬆️ After completing the upgrade process, be sure to clear your browser cookies.

    ⬆️ Upgrading from v3

    ⬆️ Please see the upgrade instructions here.